あさりのみそしるダイアリー

ブラック社員がお届けする一貫しないネタの数々・・・おあがりよ!

最近、CyberLink PowerDirector9 の挙動がおかしい・・・

商品レビューの動画なんかを作成するのによく使う、1年くらい前に購入したCyberLink社の動画編集ソフト「PowerDirector9」について、最近なんだか挙動がおかしいです。


イメージ 1

編集した動画の出力をするとこんな感じにエラーが出ます。


イメージ 2

イメージ 3

イメージ 4

あと、タイムライン(でいいのかな?)から動画を呼び出そうとすると、数フレームごとにいちいち「レンダリング中...」という表示が出てきます。

ちなみに、先述の動画生成時に、エラーが出ずにファイル出力が正常に行われている場合にもこのような表示がでます。

つい最近までは出なかったんですけどね。
なにか最近のインストールで競合するようなものでもあったのかと、ひっかかりそうなものをアンインストールしたり、PowerDirector9を再インストールしてみたりしましたがダメでした。

そういえば、BDドライブにバンドルでついていた「DVD MovieWriter 7」でもエラーが出ました。キャプチャしなかったので何のエラーだったのかは忘れてしまいましたが、こちらは再インストールしたら直りました。



現状で使い物になる動画編集ソフトがPowerDirectorくらいだったので、なんかちょと残念な感じに・・・。
サポートにでも問い合わせしてみようかしら。。。メールで。




更新 : 2012/11/7


結果的には、また正常動作するようになったということで、その報告です。


イメージ 5


挙動がおかしくなる前と同じように、スムーズな動画の編集や出力ができるようになりました。
(ちなみに、使えない間は、Windows Live ムービーメーカーを使っていました。)


結論として、今回の問題の解決策は以下のようになります。

解決策1 : グラフィックドライバをダウングレードする方法
NVIDIAのウェブサイトから自身の環境に該当するドライバのうちバージョン301.42(またはこれ以下)のドライバをダウンロードし、インストールしてください。

〇 NVIDIAドライバダウンロード
http://www.nvidia.co.jp/Download/Find.aspx?lang=jp


解決策2 : 最新のPowerDirectorである「PowerDirector11」を購入し、インストールする方法
同様の症状が出る場合、10月25日に提供を開始した「PowerDirector11 ビルド2215」を適用することで正常に使用できるようになります。


今回の不具合は、NVIDIAのグラフィックドライバとの相性問題が原因でありますが、PowerDirector9(あるいはPowerDirector10でもそうですが)での本件に対するアップデートパッチの提供の予定はないそうです。

最新のドライバもPowerDirector9も両方使いたければ新しいのを買えというのは、あまり納得できるものではありません。

しかし、とりあえずドライバのダウングレードにより動作するようになったことと、現状ではグラフィックドライバが古いことによる別の部分での不具合は生じていないので、よしとしましょう。
あくまで、現状は・・・ですけどね。今後、いろいろやっていく中で、ドライバが古いからムリですなんていう問題が起きたら、またやっかいなことになりますが、その時のことはその時に考えることにします。




最後になりますが、コメントをしてくださったみなさま、ありがとうございました。


不具合が出た当初は情報もなく、ちょうどその頃、ちょっと古いUSBウェブカメラなどのドライバをインストール・アンインストールしていたので、そういったことによる自分の環境だけの特異な現象だと思って、サポートに問い合わせもせずに問題を放置していました。今調べると、価格比較サイトなどでちょこちょこ散見されますね。

この期間にどれだけの人が同じ問題の直面したでしょうか。
不具合の原因をインターネットで検索して、開いたページがしょうもないと、ちょっとイラッとしていまいますよね。

そういうことを考えると、早い段階でこの問題にぶつかった私が、もっと早いうちに問い合わせをして、わずかでも解決へのアプローチを残しておくべきでした・・・。